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1 Driver installation for the Debugger

Connect the Debugger and PC with USB cable, and then the ‘new hardware search window’ will open
as figure 1.1 below.

Select ‘Automatically setup the software (I)’ and click the Next (N) button.

YWelcome to the Found New
Hardware Wizard
This wizard helps you install zoftware far;

USE <> Serial

Z'\.') If your hardware came with an installation CD
= or floppy disk. insert it now.

‘what do you want the wizard to da?

(®) Install the software automatically (Fecommended)
() Inztall frorm a list or specific location [Advanced]

Click MNext to continue.

[ Mext = ] [ Cancel

[Fig.1.1] The new hardware search window 1
If it is not automatically installed, select the ‘Install from a list or specific location (Advanced) and set

our attached driver as below.

2|

Select the Folder that contains drivers For wour hardware,

Please choose your s¢

(%) Search for the besl| _"| SR P
Usze the check boy # e Companyork
pathz and removal 3 &3 Dsbugger
I 1 e e =l [ CDM 2.04.16 WHQL Certified
) I amdes
Ll :
Include thiz ) 386
(IR H | & leays
| + | & MP3
() Don't search, | willl & L& MPKI
Choose this option)| - - OFFIEEZDD? hat
the: driver you chad ) wizISP_compact_verl 0 2
To wigw any subfolders, dick a plus sign abowve.,
[ (a4 ] [ Cancel ] _]

[Fig.1.2] The new hardware search window 2

Wait for searching the device driver of the Debugger. When the device driver installation is completed,
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click the END button to finish.

Completing the Found New
& Hardware Wizard
The wizard has finished installing the software for;
% USE Serial Converter
Click Finigh to cloge the wizard.
1

Completing the Found New
Hardware Wizard

The wizard haz finished inztalling the zoftware for:

y LUSE Serial Part
ra—"

Click. Finigh to cloze the wizard.

[Fig.1.3] Completing the new hardware searching #2
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2 Connect the Debugger

This section will explain how the Debugger is connected with iMCU7100EVB. Connect the
Debugger to the DTAG of IMCU7100EVB.

[Fig.2.2] W7100A / W7100 Debugger

Connect the other DTAG cable between the Debugger and iMCU7100EVB. The red line of
DTAG cable must be connected to line number 1 of iMCU7100A DTAG socket. Also connect the
USB cable between the Debugger and PC. Next, insert the power cable to the IMCU7100EVB,
and push the EVB reset button as figure 2.1. Then, push the debugger reset button of the
Debugger. Confirm the LED5 (RUN LED) after pushing these reset button.

© Copyright 2011 WIiZnet Co., Inc. All rights reserved. Ver. 1.0
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If the Debugger successfully recognizes the W7100A / W7100, the LED5 (RUN LED) will turn
on. But if the LED5 is not turned on, it means that W7100A / W7100 is not recognized. Check
the connecting cable or try to reset the IMCU7100EVB and the Debugger. The LED5 should be
turned on before using the W7100A / W7100 Debugger.

© Copyright 2011 WIiZnet Co., Inc. All rights reserved. Ver. 1.0
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3 Installation of the W7100A / W7100 Debugger

In this section, the installation of W7100A / W7100 Debugger is explained. First, run the
W7100A / W7100 Debugger install file.

a g'."?tHZIEIIiJ_EI:uug er.eux@ d
M Getup Launcher Unicode
D /1201

[Fig.3.1] The W7100A / W7100 Debugger install file

Then the installation of iMCU7100EVB debugger is started. Push the Next button to setup.

Welcome to the InstallShield Wizard for
W7100Debugger

| The InstallShigld(R) Wizard will allows vou ko modify, repair, ar
remove W7 100Debugger. To continue, dlick Next,

|Ne><t| | o

[Fig.3.2] Setup the W7100A / W7100 Debugger

a0 IShield Wizard

InstallShield Wizard Completed

| The InstallShield Wizard has successfully installed
‘W7100Debugger. Click Finish to exit the wizard,

i Finis ||

[Fig.3.3] End of debugger installation
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4 KEIL Project

Projects that are supported by the W7100A / W7100 debugger are as below.
® Keil uVision2 project
® Keil uVision3 project
® Only hex file (Restricted symbol function)

¥ The W7100A / W7100 Debugger don’t support the KEIL YVision4 or upper version project. But user
can easily convert the pVision4 to pVision3 project as shown in the figure 4.1 to use the W7100A /

W7100 debugger.

File Edit View [Project | Flash Debug Peripherals Tools SVCS Window Help

OE dd| New pVision Project.. 58 “ Q,
B New Multi-Project Workspace...
- Open Project...
Project > ERIAI
—— Close Project Ty B [F
ErE3 Target 1 |
163 Source ¢ Export » Save Project to

i~ [ STAR Manage » Save Multi-Project Workspace to pVision
-85 delay [

ice for Target Target1'..

oopl Remove File ‘wizmemepy.c'

Ll e e 3ave Project to pVisions format

socke Clean target

TCPI (4] guild torget Save Multi-Project Workspace to pVision3 format

X ason, Wrong operation c¢
e =
WIZIT 551 Rebuild all target files

£ Batch Build... [y it's mot to pe compiled " _ SERTAL UNUSED Block"

<Fig.4.1> Save Project to pVision3 format
% Caution on W7100A / W7100A Lock function
The W7100A / W7100A has the memory lock function. If the lock was set, user cannot use
the W7100A / W7100 debugger because it cannot read anything from W7100A / W7100A
memory. So user should unlock to use the W7100A / W7100 debugger properly. It is easy to
unlock using the WizISP program. As shown in the figure 4.2, clear the check box and click the
“Lock” button. Whole memory will be erased after the unlocking so user should re-write the
firmware again.
Please refer to the Wiz ISP user manual for more detailed information about WizISP. WizISP

program and user manual are available on the WIZnet website.
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2 WizlsP (v2.00.0) . ==
File  Device Options Help
" £ 4 = 4 i
@ - . A 800.900
Load HexToBin | Edit Save | Erase Blank | Program Read Verify Auto Run | Help Exit
COM Port Configuration Hex Editor
Port = Bddrss (Hex) 00 01 02 03 04 05 06 07 O 08 OR OB OC OD OE OF 012345678 3ABCDEF
: coms
Dt | COM b PSSR F rrrrrr R R R FF FF FF FF FE FE PR FR P M. ... L.l -

Baud: |115200 Close
Flash Operation Mode

© Code () Data [ Set |
[ Code [#] Data | Lock |

Auto Task Selection
[¥] 1, Flash Eraze

= = | Flash Operation Mode — f----ooovoo oo

@ Code ) Data Set iy il b
[] Code [ Data e g

e FF FF FF FF FF FF FF FF FF FF FF F
[v] 2. Blank Check FF FF FF FF FF FF FF FF FF FF FF FF FF v v v v v v v em e m e m e s
[7] 3 Pragram FF FF FF FF FF FF FF FF FF FF FF FF FF v v v v v e v mm e m e m e s

: F F FF F FF F o ]|
] 4. Verify FF FF FF FF FF FF FF FF FF FF FF FF FF
: FF FF FF FF FF BF FF FF FF FF FF FF FF  « v v v v eee e e e n s -

]
a
0
A
0

L T (= i
<Fig.4.2> Unlock the W7100A / W7100A using WizISP program

The W7100A / W7100 debugger cannot recognize multi directory structure of KEIL project
so all project file and source file must be placed in same directory to use W7100A / W7100
debugger. And the ‘make hex file’ option and ‘make symbol’ option should be activated in
the KEIL project. If they are not activated, the W7100A / W7100 debugger cannot find the hex
file to load. Also, an error message could appear even if it finds the hex file.

Since the W7100A / W7100 debugger use slower clock than normal running clock, running
speed under the debugging mode is very slow. So we recommend that don’t use a delay

function or something like that.

First, open the KEIL project.

Click ‘Project’ => ‘Options for Target ‘Target name’ menu.
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k! Test_Driver - ision3

&

ER=2 - I W R
- =@ 8 a

[m=]=] o

File Edit “iew [Project] Debug Flash Peripherals Tools SYCS Window Help

EE L% AR @
4o 7 g

LOAD

Project Workspace

~ =]

=54 Target 1

E-£5 Source Group 1

¥l STARTUR, &51
farmerncpy,c
main,c
serial.c
socket.c
wi100,c

Bl=are e

¥ ﬂa;‘félTar!;|et1

e =

=10l x|

~1[aa] #

® -
: 4
&
2
=
_g- vI
8 4 I 4 I }I HI\Build .& Command }\ Find in Files ," ” 4 I 3

A

Check the ‘Create HEX File’ option from the ‘Output’ tap as figure 4.2.

[Fig.4.3] Open the KEIL project

Options for Target "Target 1° x|

Device | Target Output I Listing | User | C&1 | 481 | BL51 Locate | BLS1 Misc | Debug | Ltilities |

Select Folder for Objects. ..

| Name of Executable: ITESLD Tiver

% Create Executabls; T est_Driver

¥ Debug Information

V¥ Browse Information

I Create HEXFile  [es Fomat [HEx-80 4|

¢ Create Library: ' Test_Driver.LIB

[T Creats Batch File

0K I | Cancel I | Defaults

© Copyright 2011 WIiZnet Co., Inc. All rights reserved.
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[Fig.4.4] Output tap of the ‘Options for Target’ window

Select the ‘Listing’ tap and check the ‘Symbols’ option of the ‘C Compiler Listing’ region.

Options for Target "Target 1° x|

Device | Target| Output Listing |User | C51 | A1 | BL5I Locate | BL5! Misc | Debug | Utilities |

Select Folder for Listings. .. | Page 'width: |1 20 _l: Page Length: IEE _l;

W C Compiler Listing: % lst
v Conditional

[ Hinclude Files [ Azsembly Code

[ CFPreprocessar Listing: 5. ‘

W fszembler Listing: W lst

[+ Conditional [ Symbalz Macros: IFinaI expanzion anly ‘I [ Cross Reference

¥ Lirker Listing: T est_Driver. mS1

vV Memary Map [V Public Spmbols [V Line Mumbers [~ Cross Beference

¥ Local Symbalz ¥ Comment Records W Generated Symbols
¥ Library Symbols

[0]4 I Cancel | Defaults | Help |

[Fig.4.5] Listing tap of the ‘Options for Target’ window

Also check the ‘Symbols’ option of the ‘Assembler Listing’ region. The ‘Assembler Listing’ is optional.

Click the ‘OK’ button to finish, and compile the KEIL project.

Confirm the HEX file in the project directory after compiling.

© Copyright 2011 WIiZnet Co., Inc. All rights reserved. Ver. 1.0
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= C:\LOOPBACK_TCP

File Edit Wiew Favorites Tools Help

eBack = '\) 1:5 pSearch H\?‘ Faldzrs -

Address |3 C:\LOOPBACK_TCP

= =
File and Folder Tasks

Iﬂ Rename this file loopback. loopbadk, LOOPBACK, LOOPEACK

a Mowe this file

Copy this file
LOOPEACK LOOPEACK LOOPBACK. hex LOOPBACK. Inp

@ Fublish this file to the Web
@ E-rmail this file
V€ Delete this file

Other Places

<ge Local Disk {:)

[} My Documents -t
| Shared Documents
a My Compuker
.a My Metwark Places
loopback,LST LOOPBACK, MAP LOOPBACK, Opt LOOPBACK,_Opt.Bak,

Details

E

[Fig.4.6] Hex file of the KEIL project

If the KEIL project includes the assembly code such as xxx.SRC file, the ‘Generate Assemble

SRC File’ and ‘Assembler SRC File’ options must be checked.

First, open the Options for File ‘xxx.c’ that uses the Assemble code.

Bl File Edit View Project Debug Flash Peripherals Tools SVCS Window Help
- Y Rl e e 1 T R - R | o @ 11
SEES KL &gl & E

- x|

Options for File 'wizmemcpy.c

Open #wizmemcpy.Ist

Rebuild all target files
Build target
Translate D:#WIZnetw_PurpleW7 100%_W7100_App _Mote ] wApplicationsWTCPWTCPs_modi 1cpy.c

Stop build

k EE

New Group
Ad to Group.

A Manage Components
Remove File ‘wizmemcpy.c'

Include Dependencies

Project Workspace (= =)
02 | (c)COPYRIGHT WiZnet Inc. ALL RIGHT RESERVED =
=8 Target L 03| V710D drver
=43 Source Group 1 04 i
- [f] STARTUP.AS1 Bg 7+
*
delay.c 07 | afile wiznencpy.c
dc 08 | @briet Define memory copy function between MCU memory and TCPIPCore memory
03|+
opback ¢ iy
ain.c 1
rial.c 12 | #include "w7100.0"
cleet 13 | #include "wizmemcpy.h”
14 | #include "TCRIFCore.h”
PIPCore.c 15
15 | #datine GENEOLL 0PD

42 EA = Edback;
43 DPXO = tmp_DPXO:
44
45 | Helse
a6 | /- 4 f
i I<] | :
EINIEIESA delay.c [ wizmem... |

[Fig.4.7] Open the Options for File ‘xxx.c’

© Copyright 2011 WIiZnet Co., Inc. All rights reserved. Ver. 1.0
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Then, check the ‘Generate Assembler SRC File’ and ‘Assemble SRC File’ options.

Options for File "wizmemcpy.c' @
Properties ]CEI |
Fath: |D:WWIZnetW__PurpIeWWNDDW__WNDD_AppIicatiun_Note_IntegratedVerWAppIicatinnsWTCPWTCPs
File Type: [C Source file | arget Bl
Size: [2019 Bytes [ Always Build
last change: |Fri Apr 22 11526 2011 ¥ Generate Assembler SRC Fil
v Assemble SAC File
\ [+ Link Publics Cnly
|| Code Bank:
Stop on Exit Code: [Not specified -
Select Modules
o Always
Include:
Custamn Arguments: |
=l E=/ P Defaults SEE

[Fig.4.8] Setting the Options for File ‘xxx.c’

© Copyright 2011 WIiZnet Co., Inc. All rights reserved. Ver. 1.0
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5 Debugger menu

5.1  Open project

The W7100A / W7100 debugger can debug the KEIL project or the hex file. To debug the

KEIL project or the hex file, run the W7100A / W7100 debugger and open the hex file.

Open Project.

The Open Project command is used to open a project.

Click the E icon of the toolbar. It can also be done by clicking Project Menu => Open or

pushing the short key Ctrl + O

The file open browser is opened as figure 5.2 ‘File open browser.’

Bz B TTiH EEeEpEEEEE F.
BHVO®|» a=EEEa,
W ace a X
+ (24 project : Empty |Register -
E== A
@= Z
Register Value
B Default Registers -
RO 0x00
A1 0x00
Re 0x00
R3 0x00
R4 0x00
RE 0x00
RE 0x00
R 0x00
& 0x00
R o1 d
Azzembly nx
| 4ssembly ~| [Search =l
i
Marne | Walue | Type | Addres: ~
W
< >
Hs. @l [®e. s [Eo. @e. @ &Ec. |
Ready NU

[Fig.5.3] Open project

© Copyright 2011 WIiZnet Co., Inc. All rights reserved.
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. W7100 Debugger

Project  Help
|l 21| & & T 7
;| @ ¢

SEEy IEEEES .

Lok, it I@ LOOPBACK_TCP

x| & @ ek E-

LOGPBACK. hex

My Recent
Documernts

&

Desktop

iy Documents

@

w Computer

&

M Netwark,
Places

File name:

[LooPeack

Files of type:

| HEX File % hex)

j Open |
[~ |

Cancel

[Fig.5.2] File open browser

If the user opens the project that is consisted only with a HEX file, the Debugger will show

a caution message. And it shows only ‘Assembly window’.

W7100 Debugger

RTUP, &A51

ZE & TTH iy EEEEREID .
g WRPOR ) @E[E=(==,

S5 (G MAING | (6] FARMEMCPY.C | [] STARTUP.AST x

- [ project : Test_Driver

|Register |
- = Source Files 117 ?8TACK SEGMENT  IDATA Al s
&8 MAIN,C 118 oE &
&) FARMEMCPY.C 119 | REEG ?ETACK Register Yalue
&4 STARTUP, A51 i1zo i D® 1 B Default Registers =
1z1 _ RO %00
1z2 | EXTRN CCDE (?C_START) Rl =00
123 | BUBLIC ?C_ STARTUPR Rz 0x00
— - R3 0=00
g EE T AT 00000H fid 000
126 03?0 STARTUP: TIME STARTURL fis 0:00
127 = RE 000
128 Pt b b insmEe 7¢_C51STARTUR i? g:gg
123 R M nn j
130 STARTUPL:
131 Pob b ANL OFFH, #07FH v
< >
Azzembly
#ggembly | [Search =l
oD@
126 : 20_STARTUE: Lame srarmo | [Name [ Value [ Tupe [ Address [~
0> 0x0000 02Z00LE LIMP Loo0l
0x000n 020126 LIMP L0OOD
0x001h  02015E LIMP L0OOD
131 : ANL OFFH, #07FH
0x001e S3FF7F LO00L: ANL OFFh #7Fh | v
134 : mov ro,41p/v| ESe.. lgm-" lG"“ lﬁlSy..‘ l@'Da'"l Ex'"l@ Bl “ﬁc”'"]
Ready MUK
[Fig.5.3] Complete opening the project
© Copyright 2011 WIiZnet Co., Inc. All rights reserved. Ver. 1.0 15
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*Note: When the user open the project and have the error message like shown below, the user must
delete the xxx.SRC file in project directory, and check both the ‘Generate Assembler SRC File’ and
‘Assemble SRC File’ options to avoid error on the W7100A / W7100 debugger.

For a more detailed solution, please refer to section4 ‘KEIL Project’.

w7100 Debugger

' O'E‘tiun error! uVision Project Workspace-» FARMEMCPY C file—> Click right mouse button —» Select "Option for File
< FARMEMCPY, C" —» Check 'Generate Assembler SRC file and "&ssemble SRC file' in Properties tab

[Fig.5.4] Open error message

Reload project
The Reload command is used to reload a project. When the loaded project is changed, click
the reload toolbar button [#] to reload the project. It can also be done by clicking ‘Project’

=> ‘Reload’ or pushing the short key F4.

Close project
The Close project command is used to close a project. Select ‘Project’ => ‘Close’ or push
the short key Ctrl + Q.

*Note: While using the W7100A / W7100 debugger, the user must use the ‘stop’ command in

order to close the debugger.

5.2 Initialize the W7100A / W7100 Debugger

This section is for initialization of the debugger and iMCU7100EVB
i W00 Debugger - STARTUP, &51

EZE @S- TTH s fEEEEE .

[ @deos » a=(=2(-

[Fig.5.5] Initialize menu

-

Debugger and board reset
The Debugger and board reset command is used to reset the debugger and board
simultaneously. If breakpoints were set, all initialized breakpoints will be removed.
To reset, click the E]; button on the toolbar, or select ‘Tool menu’ => ‘Init Debugger and

Board reset’ menu. Then the Debugger and board will reset.

© Copyright 2011 WIiZnet Co., Inc. All rights reserved. Ver. 1.0
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Board reset only
The Board reset command only is used to reset the board only. If breakpoints were set, they
will be maintained. To reset the board, click the @ button of the toolbar or select the

‘Debug menu’ => ‘Board reset’. It can also be done by short key F2.

Image load

The Image load command is used to load an image.

Write the HEX image for debugging to the Flash memory.

Click the “33 button or select Debug menu => Image Load menu to execute ‘Image Load.’
It can also be done by short key F3.

If the image writing and verifying is successful, ‘Write OK’ message will show.

Note: If there is a mismatch between the board image file and present HEX file, the error

message is shown when execute the ‘Debugger commands’ such as ‘Continue, Step, Next’.

W00 Debugger

!E Error!! Load Image mismatch, please reload Image,
L

[Fig.5.6] Load image mismatch
Debugging

The W7100A / W7100 Debugger serves ‘Debug’ and ‘Tool’ menu and Toolbar button for
debugging.

W00 Debugger - STARTUP, 451

EEZ @& TTIH aE3EEEED .
% @O P » m=(z=(==2 ]

[Fig.5.7] Deugging menu

Go to Source Line
The Go to Source Line command is used to move the cursor to the wanted source line. To use this

function, select the ‘Tool’ menu => ‘Go to Source Line’ or use short key Ctrl + G.

Find
The Find command is used to find some words on the source window. To use this function, select the

‘Tool’ menu => ‘Find’ or use short key Ctrl + F.

© Copyright 2011 WIiZnet Co., Inc. All rights reserved. Ver. 1.0
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5.3 Run and Stop

This section will explain how to use commands like step in, out, next, and more
Continue
The Continue command runs the program until the Break point is met. To use this command,
click the [+ button on the toolbar or select the Debug menu => Continue. It can also be
done by short key F5.
During the Continuing state, user cannot use the debugging menu. In order to use the

debugging menu, execute the Stop command.

Stop

The Stop command is used to stop the running program. To use this command, click the

4 button on the toolbar or select the Debug menu => Stop. It can also be done by short
key F6.

The debugging commands (Search, memory view, break point, etc.) are executed only in the Stop state.

Step
The step command is used to run only one specific line among all lines. The Step command is executed
in units of one line of the C code. If there is a Function call, the Step command will enter into the
related Function. After the execution, the debugger is stopped and waits for the next command.
To use this command, click the button on the toolbar or select the Debug menu => Step. It
can also be done by short key F11. *E If the user has only the HEX file to debug, the

Step command executes one instruction, just like the Stepi command.

Next

The Next command is basically the same as the Step command. The Next command is executed in units
of one line of the C code. But if there is a Function call, the Next command does not enter into the
Function. After the execution, the debugger is stopped and waits for the next command.

To use this command, click the button on the toolbar or select the Debug menu => Next. It
can also be done by short key [= F10. If the user has only the HEX file to debug, the

Step command executes one instruction, just like the Nexti command.

Stepi
The Stepi command executes only one instruction. If the instruction is a Function call, the command

enters into the related Function. After the execution, the debugger is stopped and waits for the next

command.
To use this command click the button on the toolbar or select the Debug menu => Stepi. It

can also be done by short key F7.

© Copyright 2011 WIiZnet Co., Inc. All rights reserved. Ver. 1.0
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Nexti

The Nexti command executes one instruction. But the command does not enter into the related
Function even if the instruction is a Function call. After its execution, the debugger is stopped and waits
for next command.

To use this command click the EE button or select the Debug menu => Nexti.

It can also be done by short key Fé.

Run to cursor line

The ‘Run to cursor line’ command executes the code until the cursor on the debugger source window is
met.

To use this command, select the push the mouse right button => select ‘Run To Cursor Line(n)’ or

select the Debug Menu => Run To Cursor Line.

BEEE(E=,

CWT00C | (€] SOCKET.C | (] SERIALC | (] MAIN.C % | (] FaF

55

56 uint8 xdata txsize[MAX SOCE_ NUM
57 uint8 xdata rxsize [MAX SOCE_ NUM
S8

55 whila (1) -

60 Goto Source Line(L)

61 et Break(B) tialize @
g2 Insert Yariable Window(\)

63 Fun To Cursaor Line{M)

6d =etSHER (mac];

] s=tGAR (gw) ;

o6 =2t SUBR (=n) ;

=7 A= DT faam b

[Fig.5.8] Run To Cursor Line command

Sometimes the ‘Run To Cursor Line’ command continues when the cursor is not properly set.

If that is the case, execute the Stop command to stop it.
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5.4

This section will explain how to set/clear and find breakpoints. The breakpoint can be set

Break Point

only when the debugger is not being used. If the user was using the debugger, use the Stop

command to stop in order to set the breakpoint.

Project Tool Window Environment Help
EE B TTHN B EEy QEEEERHSE.

@ 1fo O 9]

p @FE[EFE(EE .

o] w00 | |c) SOCKETC | (€] SERIALC | [C]MAIN.C x| (] FARMEMCPY.C | ] STARTUP. 451

o X §EBreakPoint

?Euézi:cgt;f;;dme’ 43 // uint8 xdata tmp[6&] = {0,0,0,0,0,0}; A |2fgf‘fr =l

&4 WH00,.C S0 GE 4
o SOCKET.C 51 uint8 xdata ip[4] = {19%2,168,1,86}; // fo: Register Value
< SERIAL.C Sg-.- uint8 xdata gwl4] = {19%2,168,1,1}; /£ = Default Registers -
€ MAIN,C s34 @ uint8 xdata sn[4] = [255,255,255,0}; e RO (w9 I
o FARMEMCPY.C 54§ uint8 xdata mac[6] = {0x00,0x08,0xDC, 0xll, 0x22, 0xA86}; | il 0x18
] STARTUP. 451 59 RZ Ox0e —

sd@ wint8 xdata txsize[MAX SOCE_NUM] = {2,2,2,2,2,2,2,2}; —| B3 Ot

5| wints xdata rwsize[MaX socE_NUM] = (2,2,2,2,2,2,2,2}; :; BX'UBU

] I

iE RE 0%08

& Tnit8051(); // Initialize 8051 2? gigg

(3 iinchip init(); B 08

&3 sp Dl

e SetSHAR (mac) ; DPTRO 7700

64 SetGAR (gw) ; PC§ 0x00de

[ 3etSUBR (sn) ; = PSW ﬂ

& set8IPR(ip);

el | sysinit(txsize,rxsize); i

< | >

pssemnbly | |[BreakPaint -
ofE X ok
URO053 7303 FOV RL #0C3E Toms RET] =
0x005b  7E00 MOV RE #0h IN.C . Line + /4 main + 21 1
AN, C | Line : 52 main + 19
0x005d 702 MOV R7 $h AN C - Line ¢ 53 main + 38
AN, C . Line : 54 main + 57
0x005f 120950 LCALL 10016 AN, C - Line ! 56 main + 76
AN, C | Line : 57 main + 95
57 uinté xdata rasize [MAX SOCK NUM] = (2,2,2,2,2,2,2,2} ||IMAIN.C  Line : 57 main + 97
AN, C | Line : 57 main + 39
0x0062 7834 MOV RO #84h MAIN.C  Line : 57 main + 101
R AN, C | Line : 57 main + 105
0x0064  7C00 MOV R4 $0h MAIN C © Line : 57 main + 103 3
0x0066 7001 MOV RS #1h
0x0068 7BEF MOV R3 #0FFh
0x006a 7A0E MOV R2 #0Eh
0x006c 7901 MOV R1 #0DLh
0x006e 7E00 MOV RE #0h
0x0070 7E02 MOV R7 #ch
A
0x0072 120950 LCALL 10016 E
xouT | @break. | Elsearch|[Fivate..] (& Exter.][E Fias..] & lob.. [[& code..] 7 Symbol & Local..|
Ready

[Fig.5.9] Break point of the debugger
Set break point
To set the breakpoint
1. Click the shadowed region side of the source window
. Locate the cursor and click the " utton on the Toolbar
. Locate the cursor and click the Debug Menu => ‘Set Break’

2
3
4. Double click the C code line in the source window
5. Double click the Assembly code line in the Assembly window
6

. Locate the cursor in the Assembly window and click the _3 he Assembly Toolbar
7. Short key F9
Set the breakpoint and execute the Continue command. Then the debugger will run until it

meets the breakpoint and will stop at the checked breakpoint. After that, the user can use
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other Debug commands. If the PC(program counter) can’t move to the breakpoint, the
debugger will keep running. If that is the case, the user should execute the Stop command to

stop it.

Clear Break
The Clear command is used to clear the breakpoint.
1. Click the checked breakpoint . region
. Click the | _} button on the selected breakpoint line
. Locate the cursor at the C code line and click the Debug Menu => Clear Break
. Double click the breakpoint directly on the C code line

. Double click the breakpoint directly on the Assembly code line

o U1 N W N

. Select the breakpoint on the Assembly code line and click the L@ button

on the Assembly Toolbar

7. Select the breakpoint on the C code line and select the & button on the Breakpoint
Toolbar

8. Short key F9

Clear All Breaks
The clear all breaks command will clear all breakpoints, both from the C code and Assembly
code. To clear all breakpoints,
® C(lick the ,.‘:'J button on the Breakpoint Toolbar (Breakpoint window)
® Click the & button on the Toolbar

® Select the ‘Debug’ menu => ‘Clear All Breaks’

Goto Next Break Point

The Goto Next Break Point Command is used to move the cursor to the next break point.
To use this function,

Click the g button on the Toolbar

Select the ‘Tool’ menu => ‘Goto Next Break Point’

Goto Previous Break Point

The Goto Previous Break Point command will move the cursor to the previous break point. To use this
function,

Click the '::I-J button on the Toolbar

Select the ‘Tool’ menu => ‘Goto Pre Break Point’
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Break Point Window
The Break Point Window command shows all checked breakpoints.
The break point Toolbar buttons are as below.
® if : Clear the selected breakpoint
® 3 : Clear all breakpoints

® 4| : Move to selected breakpoint

Source and Assembly window
In the Source window and Assembly window, user can see the source code and assembly
code. The user can also use Debug commands.

In the source window, user can check all variables and add it to the search window.
e W00 Debugger - STARTUP, &51

5@ 38 TTiHl seezsaaEaads.
i B PON »p @ FE(EE(E=E,

[Fig.5.10] Window menu

To use the Assembly window, click the —] button on the Toolbar or select the Window

Menu => Assembly menu. The Source window is always shown unless opening only HEX file.

Source Window

I[ [ warooc | &) sockeT.c | [c] SERIALC | (] MAIN.C x| [c] FARMEMCPY.C | [c] STARTUR, 451

48 // uintB sn_sr_tmp, sn_mr_tmp; ~

49 // uint8 xdata tmp[6] = {0,0,0,0,0,0};

S50

51 uint8 xdata ip[4] = {152,168,1,86}; £ fo:

52 uintl =xdata gw([4] = {192,168,1,1}; /i Ee

53. uint8 xzdata sn[4] = {255,255,255,0}; I

54 . uintf xzdata mac[6&] = {0x00,0x08, 0xDC, 0xl1l, 0x22, 0xB86};

55

56 @ uintf xdata txsize[MRX SOCE _NUM] = {2,2,2,2,2,2,2,2}; 5

57 o> uintf xdata rxsize[MRX SOCK NUM] = {2,2,2,2,2,2,2,2};

ig | Goto Source Line{L)

&0 Initg0s] SetBreakd 8051

61 iinchip Insert Wariable Windowd )

62 Fun Ta Cursor Line(M)

63 =et3HLAR (mac) ;

64 setGAR (gw) ;

65 =etSUBR (=n) ;

cc @ setSIPR(ip);

&7 sysinit (tx=zize, rxsize) ;

68

Y | PutStringln |["S==S==========S====sS===s====s=========1

70 PutStringlm (" W7100 MNet Config Information"); v
£ | >

[Fig.5.11] Source Window menu

The Source window is shown in the figure 5.11.
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) LJI} : indicates the PC (Program Counter) in the source code
) . : means Breakpoint is set on this line
) : the breakpoint can only be set on this shadowed line

Click the mouse right button in the Source window, user can see the Source window menu
as in the figure5.11.

® Goto source line: Move the cursor to the set line

® Set break: Set the breakpoint

® Insert Variable window: Add the variable to the Search window
°

Run To Cursor Line: Run the C code to cursor line

Moreover, the Source window can assist some functions as below.
® Can set the breakpoint by double clicking the C code.

® Show the indicated variable value when the mouse pointer on the variable.

Assembly window
The assembly window shows the currently running assembly code. Also if the user clicks the C code at
the source window, it shows the related assembly codes. If the user opens only the HEX file without Keil

project files, only the assembly window will be shown without the source window.

|Aszembly ]
33
0x0044 7TAOE MOV R2 #0Eh e
0x0046 79C3 MOV R1 #0C3h
0x0048 7TEQO MOV RE #0h
0x004a 7F0& MOV R7 #6h
0x004c 12095D LCALL LOO1&
he uintf xdata txsize[MAX S50CK NUM] = {2,2,2,2,2,2,2,2};
I:) 0x004f 787C MOV RO #7Ch
' 0x0051 7C00 MOV R4 #0h
0x0053 7001 MOV RS #lh
0x0055 7BEF MOV R3 #0FFh
0x0057 7TROE MOV R2 #0Eh
0x0059 79C9 MOV R1 #0CSh
0x005L  7TEQO MOV RE #0h
0x0054 7TF08 MOV R7 #&h
0x005f 12095D LCALL LOO1&

[Fig.5.12] Assembly window
In figure5.12,
° fl:} : Indicates the PC’s location of the instruction
) . : Indicates the break point

® 1 : Shows the assemble code with related C code

° _j : Shows the break point

double click: Sets or unsets the break point
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6 Search & Variable Window

The W7100A / W7100 debugger provides various windows to see the local variable, global

variable, and the register value.

Global variable window: Shows the value of global variable in the project

Local variable window: Shows the value of local variable at the PC(program counter)
now

Search window: Puts the variable name, then it shows the value at the PC now

Register window: Shows the value of registers at the PC now

Symbol window: Shows the all symbols and its values of the project

To activate each window, select the related window on the Window menu or click the

window button on the Toolbar.

W7100 Debugger - STARTUP, AB]

53 % TTHEEs s meamoE]
HBWIPOL » @E=(EZ=(==.

[Fig.5.13] Search window

® Activate Search window: Click the ,;'j or select the ‘Search Window’ on the Window
Menu

® Activate Local variable window: Click the _ﬂ or select the ‘Local Variable Window’
on the Window Menu

® Activate Global variable window: Click the ﬂ or select the ‘Global Variable
Window’ on the Window Menu

® Activate Symbol window: Click the jﬁlor select the ‘Global Variable Window’ on
the Window Menu

® Activate Register window: Click the ﬁl or select the ‘Register Window’ on the

Window Menu

6.1 Search Window

The search window shows the global variable, local variable, or the memory value,
depending on which ones the user registered. The global/local variable windows also show
the values of variables. But usually users want to see one or two variable values and
sometimes want to see both global and local variables simultaneously. In this case, just

register the variables on the search window.
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Search -
Mame [ Value | Type | Address | ~
0:0x00:4 249, 42, 14, 255 ARRAY

00004 2,18, 106, 120 ARRAY

#:0xbad 192, 168, 1. 86  ARRAY E
5 4 U_CHAR [0:0=000008

len 1] INT [:0=000009

[Fig.5.14] Search windows

To register the global/local variables, write down the register name on the name field of
the search window.

On the search window, user can not only confirm the variable but also can modify its value.
To modify the value of the variable, click the value field on the search window and write
down the value.

To see the memory value on the search window, write in the form, ‘memory type :
address : size.” The memory types are C, D, and X. (code memory, internal data memory and

external data memory).

Ex) Code memory => C:0x1000:5
Internal memory => D:0x30:2
External memory => E:0x000300:4

Local Wariable

|Search -
Mame | Walue | Tupe | Address | ”~
5 0 I_CHAR 00000005
i 0 U_CHA&R BIN&ARY  (B) 3
| 0 U_CHAR OCTAVD (0}
ip 192,168.1.86 ARRAY
gw 192168.1.1 ARRAY DECIMAL (D)
) 25h, 250 2550 ARRAY HEX* (=)
mac 0.8.22017.34.,,, ARRAY AT
tusize 22222222 ARRAY 0w 000077C
rusize 2.2.2.22222 ARRAY #0x000024
W

=]iData Memo,,,l ] Global Vari,,,lﬁlSymbol IECDUB Memo,,,lﬂ External M., l ] Local Varia,,,l,fa Search ]

[Fig.6.1] Display format

User can select the display format by clicking the mouse right button on the search, local

and global window such as binary, octal, decimal and hexadecimal.
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6.2 Local Variable Window

The local variable window shows the value of the local variable in the PC located function.

Search -
Marne | Walue | Type | Address | ~
5 4 J_CH&R D:0x 000008
len 1] IMNT 0:0x000009
i 0 U_CHAR 0:0= 000008
ip 192,168.1,86 SRRAY 0w 000062
gy 192, 166,11 SRRAY = 0x00006E
5N £hh, 255, 255.0 BRRAY 0= 000072
mac 0.8.220.17.34.,.., ARRAY #:0=000076
tusize eeeeeee? SRRAY wa0x00007C
resize 22222222 ARRAY 0w 000054
b

[Fig.6.2] Local variable window
The local variable window has almost the same interface as the search window. But it is not

allowed to register a new variable or a memory address.

6.3 Global Variable Window

The global variable window shows all the global variables in the project. The global
variable window has the same interface as the local variable window.

Global Yariable -
Marme | Walue | Tupe | Address |

data_buf 2867 PTR D:0x00005F

local_port 33823 L_INT #:0=000099

read_addr_h B4 LI_CHAR X0 00006A

read_addr_| 132 U_CHAR *:0x000069

[Fig.6.3] Global variable window

6.4 Symbol window

The symbol window shows the information of all symbols in the project. It shows the class

type and the address of the related symbol.
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Syrmboal -
Hame | Class Tvpe | Address | ~

-1 ?C_STARTUR

E30E ) F A RMENCEY
-IgE MATH

PC_STARTUFE PUBLIC C:0=000000
ACC SFRSYH D:0=0000ED
B SFRSYH D:0=0000F0
DFH SFRSYH D:0=000083
DFL SFRSYH D:0=000082
IDATALOOE SYMEOL C:0=00126D
FPLGE _SFR SFRSTH D:0=z000040
SP SFRSEYH D:0x000081
§a STARTUPL SYMEOL C:0=001264

_ICE DUMMY_ SYMEBOL C:0=000000
PO SFRSYH D:0x=000080
Fl SFRSTH D:0=000090
P2 SFRSYH D:0=000040
P3 SFRSYH D: 0=0000E0
IE SFRSYH D:0x=000048
Ip SFRSYH D: 0x=0000ES
(ﬁ W= PITRT T - N=0nnnn"2 b

apino 1abbngaq 00TLM / VOOTLM

[Fig.6.4] Symbol window

6.5

In the register window, user can check or modify the value of the register. It shows the

Register window

default registers, PSW, and special function register (SFR). To modify the value of the register,
click the field of register value and write the new value. But if the register is read only, then

the value is not changed.

Fegister -
@E=- A
[CESINA
Register Walue
B Default Registers -
RO 0xf9 ]
R1 Ox2a
§14 (O 0e
R3 O ff
Rd 014
jis] O:04
RE x4
R O:x14
A Oxf8
B 007
P 061
DPTRO Ox 0344
PC % Ox0211
B PSW
P 1
0
oy 1]
RE 0
Fo 0
AC 0
Cy 1]
B Speicial Registers
PO Oseff —
DPL 003
DFH x4
DPTR1 (0000
DPS 000
PCOM 080
TCOM Oxc0
THOD 020
TLO 000
TL1 Oxfe
THO 000

[Fig.6.5] Register window
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7 Memory window

Notice: To read a memory value of iIMCU7100EVB, a Keil project or HEX file should be
opened first. But no matter difference between Keil project or HEX file and image
which loaded to iMCU7100EVB.

The iMCU7100API debugger supports below memory windows.
) IData memory window: Shows the value of internal data memory. Update the
value when stop state after the debugger command
External memory window: Shows the value of external data memory
Code memory window: Shows the value of code memory

Flash memory window: Shows the value of flash memory

To activate each window, use the ‘Window’ menu and Toolbar as in the figure7.1.
T W00 Debugger - STARTUF, AR

FE @ TTH 8=E=Eg
i B PON »p @ FE(EE(E=E,

[Fig.7.1] Memory window

k

® Activate IData memory window: Click the =i button or select the ‘Window’

menu => ‘IData Memory Window’

) Activate External memory window: Click the ﬂ button or select the
‘Window’ menu => ‘External Memory Window’

) Activate Code memory window: Click the E button or select the ‘Window’
menu => ‘Code Memory Window’

) Activate Flash memory window: Click the ﬂ button or select the ‘Window’

menu => ‘Flash Memory Window’
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7.1 IData Memory Window

The IData memory window can show the value of internal data memory (D:0x00 ~ D:0xFF)

or modify the value.

IData Memory

2] (4] 4]

Address | o123 | 4567 | s89ap | cDEF | ”~
0x000000 :  F92A0EFF 14044414 04000000 0701138F

0x000010 : 00070008 40004000 00000000  0OOOOOO0

0x000020 : 00000000 00000000 00000000 00000000

0x000030 : 00000000 00000000 00000000 00000000

0x000040 :  000OOOOO 00000000 00000000 00000000

0x000050 : 00000000 00000000 00000000 00000070

0x000060 : 00000202 C4193516 00000000 0OOOOOO0

0x000070 : 00000000 00000000 00000000 00000000

0x000080 :  FF610344 00000080 CO2000FE  OOFCO100

0x000090 :  FFOOOGO0 00000000  S0000000 00000000

0x0000a0 :  FFOOOOOO 00000000 00000000 00000000

0x0000b0 :  FFOOOOOO 00000000 00000000 00000000 v

[Fig.7.2] IData Memory window
To modify the value of internal data memory, click the value field of internal data memory
and write the new value. All memory windows can change into the display format, such as
2/4/8 byte display unit or CHAR/INT/LONG display format. It is shown in figure7.3.

IData Memory

Start Address: l:l End &ddress: l:l

2] (a]|[2]

sddress | o123 | 4567 | ssap |  coEF | A~
0000000 : 62000000 00000100  0000O00OO 00000000

0000010 : 00000000 00000000 00000000 00000000

0000020 : 00000000 00000000 00000000 00000000

0=000040 - 00000000 0 ey
0=000050 :  oooooooo O INTIL

jooooo  oooooooo
jooooo  oooooooo

0=000060 70000000 0 |LONGIL) jooooo  oooooooo
0=000070 00000000 Dowwooos == 10000 00000000
0=z000080 FFE2FB14 00000000 00000000 00000700
0000090 FFOOO700 00000000 00000000 oooooooo
0000020 : FFOOOOOO 00000000 00000000 oo0ooooo0

W

Oe 0000l n CTAOnOO0 OO0O000n0 OOOOnOnn OnOanOnn

ﬂlData Memo,,,l ﬂGlobal Vari,,,lﬂ?ySymbol IECDde Memo,,,lﬂ External k.., l E_I'jLocaI Varia,,,lﬂSearch ]

[Fig.7.3] Change the display format
If the internal data memory value updates and the debugger command is in stop state, it

updates the internal data memory value to the iMCU7100API board.

7.2  External Data Memory Window

The external data memory window shows the value of external data memory (X:0x000000 ~
X:OxFFFFFF).
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tddress | 0123 | 4567 | 89 |  cDEF | ~
0000000 ; 07FFO0?FF  0FFFO7FF  O7FFO07FF  O7FFO7FF
O=000010 07FFO07FF  0FFFO7FF  O7FFO07FF  O7FFO7FF
0=000020 0000800 08000800  OS000800  O8000800
00000320 0000800 08000800  OS000800  O8000800
0000040 EF02217F 3C2665ES  COOODCE00  DOOODEOO
0=000050 - EO0OOES00  FOOOFS00  S0008800 90009800
0=000060 - 40004800 BOOOBS00D  3684C0A5  0D1G6C0AS
0=000070 - 0101FFFF  FFOOO00S DC112286 02020202
0=000080 - 02020202 02020202 02020202  01423DAC
0=000090 - 20008320 16270CSE  C4841FFC  714BS2E4
0x000020 - 9600F98F  4E076809  4D28A850 2124BFSS

[Fig.7.4] External Data memory window
The value of external data memory is not automatically updated. If the value of external
data memory updates on each debugging command, the speed of the debugger may be slower
due to the size of external data memory being larger than the internal data memory.
Therefore, the debugger has a button ﬂ for updating the value of external data memory.
As in section7.1 ‘IData Memory Window,’ if the user changes the value of external data

memory in the debugger, the real value of iMCU7100API board will also change.

7.3  Code Memory Window

The code memory window shows the value of code memory (OxFFO000 ~ OxFFFFFF). This

window is for reading only, it cannot be modified.

Code Memory

art Address:

2] 4] [s]@

Address | o123 | 4567 | 89aB | cDEF | ~
0=000000 - 02126478  GA?CO07D 017EFF74 OE79BE77E
0=000010 - 007F0412  095D786E  7CO07D01  7EFF7AQE
0=000020 79EEB7EO0  ?F041209  SDYE727C  007DO17E
0000030 : FF7A40E79 EF7E007F 0412095D 78767000
0=000040 - 7D017EFF  7A0E79C3  FEOO07PFOE 12095078
0=000050 - 7C7C0070  017EFF74  OE79C97E 007F0812
0=000060 09507864 7007001 FEFFFA0E 79D17E00
0000070 : 7FO081209 SD121409 121AF07E 01740079
0000080 - 76121932 7BE017400 796E1219 E37E0174
0=000090 - 00797212 19F67BO0L  7AO07964 1219CF75
0=0000a0 : OF017510 00751184  7EO17A00 797C1203

[Fig.7.5] Code Memory window
As in the section7.2 External Data Memory Window, the code memory window has a button for

g_ updating the value of code memory.

7.4  Flash Memory Window
7.4.1  Code Memory Domain

In the flash memory window, if the ‘Data memory’ option is unchecked, it will shows the
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value of code memory (0xFFO000 ~ OxFFFFFF). Basically it is same the ‘Code Memory Window’

but it can modify the value with flash write button.

Start Address: End Address: Data memory
ldEE 3

Address it 4E67 89AB CLEF
O=zff0000 aoooe0nn 02112800 08FC9cClas  20FEFEB1R
O=f£0010 : EO0861AEC DCDC1D34 OBF94160 EEDDO&ON
O=zf£0020 DFO08CE0 FAFE94E2  FAEVFSFF  BAFFATDE
O=zf£0030 BEO3FF74  FFI9FDACA  FF8DAAFS SE3DBO9A
O=zf£0040 90E0EERZ 91AF9ER? 72FDFFBS AF90FD90
O=f£0050 BEE7FF40 F980CC082 96CE9CEBC  SFA9ERI0
O=zf£0060 FFOFSFFF  BeC4BEOD EEFEEOD?  EeBDDD99
O0=f£0070 : FEB77298 00378124 DOEES028 86805480
O=zf£0080 DEFFE48C  30EGAERS 99FESEEE  ECFFCAFS
O=zf£0090 SEEF7FD4  EVFBFFDE E4FD73E0  FFBEELF?
O=zff00a0 927EFF&RE AF76FFE?  F9BDFEO4 16848 3EF
O=zff00bO 1FF313EBD EL1EEEE02 9DFEC244 FDOOODADD
O=ff00cz0 CECABATE BeLA93Ad JDF7D7E2 95EE3ERSR
O=zff00d0 SEFDD?FF  2EDDAFDF  91F700C6 70270000
Ozff00=0 92934012  ASBFDOOLN E0B9409F  AFF430C2

Elsearch | [E]Local v, | €] Global ., | £ symbol | [5]iData M., |[E] Externa..| (E] Flash M., [&]cade M.,

[Fig.7.6] Flash memory window for code memory
The basic interface of the flash memory window is the same as other memory windows. But
it has the flash write button ‘Pé. which writes the whole value of flash memory window to
the flash memory of iMCU7100API. Also it has a button E. for updating the value of flash

memory.

7.4.2 Data Memory Domain

Start Address: I:I End Address: I:I v Data memory
LR =

Address 0123 4567 G94AB CDEF

O=zf£0000 : 20008000 02112800  08FC9ClA 20FEFELR
O=f£0010 E0861AEC  DCDDID3E  (OEF94160  EEDDOGODN
O=f£0020 DFO0BCE0  FAFE94E2 FAEVFOFF  BAFFATD2
O=f£0030 Be03FF7A4 FF9FDACA FFSD8BF9 GE3IDEO%A
O=f££0040 90EDEERZ  91AF9ER?  72FDFFB:  8F90FD90
O=f£0050 BBB7FF40 F98CC082  96C89CEBC  SFASEE3N
O=f£0060 FFLFEFFF  B&C4BB00 G6FEBOD?  EGEDDDA99
O=f£0070 FEB77293 00378124 DOBB9023  868DYASD
Oxf£0030 DeFF&48C  30EcAES8  99FESFEE  ECFFCAF9
O=f£0090 8BBF7FD4 BYFBFFDS  54FD73E0  FFEEELF7
Oxff00al : 927EFFe6  3IF76FFE?  F9EDFEO4  168A83EF
Oxff00b0O : 1FF393BD BlEEBEZ28 9DFSCB844  FDOOOAOD
Oxff00c0 : CeC4BATE  BoLA9344 7DF7D732 96EE3EGSS
Oxf£00d0 SEFDD?FF  2EDDAFDF  91F700Ce 70270000
Oxff00e0 : 82934012  ASFDOO10  60B9409F  AEF430C2
O=££00£0 00C77D04  081B2908  42C2B800 0O00O0O0OQO

Edsearch | ELocal v, | E]Global ., | &2 symbol | [5]iData M., |[E] Externa,., [E] Flash M., [€]Code M.,

[Fig.7.6] Flash memory window for data memory
If the ‘Data memory’ option is checked, it will shows the value of flash data memory (0x00
~ OxFF). It can modify the value with flash write button. The basic interface of the flash
memory window is the same as other memory windows. But it has the flash write button
'Pé. which writes the whole value of flash memory window to the flash memory of

iMCU7100API. Also it has a button ﬂ for updating the value of flash memory.
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ver. 0.91 2009. 12 Modify section2 “Connect the debugger”. Add about

debugger reset button.

ver. 1.0 2011. 6 Release with W7100A lunching
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